summaryrefslogtreecommitdiff
path: root/libsecret/Makefile.am
diff options
context:
space:
mode:
authorDaiki Ueno <dueno@src.gnome.org>2019-08-13 18:12:35 +0200
committerDaiki Ueno <ueno@gnu.org>2019-10-13 06:21:38 +0000
commit2d642b5b7d0e70d8d8c9038d2306173f9cf1a7fd (patch)
treeb9901a1d09e0740fd702b281d5d239d472b5cf29 /libsecret/Makefile.am
parent9cfad7c6214e187624e165a18b64fe266ec68340 (diff)
downloadlibsecret-2d642b5b7d0e70d8d8c9038d2306173f9cf1a7fd.tar.gz
secret-file-backend: New backend for storing secrets in file
This adds a new backend based on locally stored file.
Diffstat (limited to 'libsecret/Makefile.am')
-rw-r--r--libsecret/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/libsecret/Makefile.am b/libsecret/Makefile.am
index 0e34ea3..f760e6c 100644
--- a/libsecret/Makefile.am
+++ b/libsecret/Makefile.am
@@ -60,6 +60,17 @@ libsecret_PRIVATE = \
libsecret/secret-util.c \
$(NULL)
+if WITH_GCRYPT
+libsecret_PRIVATE += \
+ libsecret/secret-file-backend.h \
+ libsecret/secret-file-backend.c \
+ libsecret/secret-file-collection.h \
+ libsecret/secret-file-collection.c \
+ libsecret/secret-file-item.h \
+ libsecret/secret-file-item.c \
+ $(NULL)
+endif
+
libsecret_@SECRET_MAJOR@_la_SOURCES = \
$(libsecret_PUBLIC) \
$(libsecret_PRIVATE) \
@@ -247,6 +258,15 @@ test_session_LDADD = $(libsecret_LIBS)
test_value_SOURCES = libsecret/test-value.c
test_value_LDADD = $(libsecret_LIBS)
+if WITH_GCRYPT
+C_TESTS += \
+ test-file-collection \
+ $(NULL)
+
+test_file_collection_SOURCES = libsecret/test-file-collection.c
+test_file_collection_LDADD = $(libsecret_LIBS)
+endif
+
JS_TESTS = \
libsecret/test-js-lookup.js \
libsecret/test-js-clear.js \
@@ -377,4 +397,5 @@ EXTRA_DIST += \
libsecret/mock-service-prompt.py \
$(JS_TESTS) \
$(PY_TESTS) \
+ libsecret/fixtures \
$(NULL)