summaryrefslogtreecommitdiff
path: root/rest-extras/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'rest-extras/Makefile.am')
-rw-r--r--rest-extras/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/rest-extras/Makefile.am b/rest-extras/Makefile.am
index c354867..fd0858e 100644
--- a/rest-extras/Makefile.am
+++ b/rest-extras/Makefile.am
@@ -57,11 +57,14 @@ RestExtras-@API_VERSION@.gir: librest-extras-@API_VERSION@.la Makefile
RestExtras_@API_VERSION_AM@_gir_NAMESPACE = RestExtras
RestExtras_@API_VERSION_AM@_gir_VERSION = @API_VERSION@
RestExtras_@API_VERSION_AM@_gir_LIBS = librest-extras-@API_VERSION@.la
-RestExtras_@API_VERSION_AM@_gir_FILES = $(addprefix $(top_srcdir)/rest-extras/, $(lib_headers))
+RestExtras_@API_VERSION_AM@_gir_FILES = \
+ $(lib_headers) \
+ $(filter-out %private.h, $(lib_sources))
RestExtras_@API_VERSION_AM@_gir_CFLAGS = -I$(top_srcdir)
RestExtras_@API_VERSION_AM@_gir_INCLUDES = GObject-2.0 libxml2-2.0
RestExtras_@API_VERSION_AM@_gir_PACKAGES = gobject-2.0 libsoup-2.4 libxml-2.0
-RestExtras_@API_VERSION_AM@_gir_SCANNERFLAGS = --include-uninstalled=$(top_builddir)/rest/Rest-@API_VERSION@.gir
+RestExtras_@API_VERSION_AM@_gir_SCANNERFLAGS = --include-uninstalled=$(top_builddir)/rest/Rest-@API_VERSION@.gir --accept-unprefixed
+RestExtras_@API_VERSION_AM@_gir_EXPORT_PACKAGES = rest-extras-@API_VERSION@
girdir = $(datadir)/gir-1.0
dist_gir_DATA = $(INTROSPECTION_GIRS)