summaryrefslogtreecommitdiff
path: root/rest/Makefile.am
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@linux.intel.com>2010-08-20 13:29:04 +0100
committerRoss Burton <ross@linux.intel.com>2010-08-20 13:38:07 +0100
commitad370df7c958389f7e814e737d883684ffabbfe8 (patch)
tree7b4133c4bc2befa3b7ec54efe459d2bf537b8611 /rest/Makefile.am
parent0ebcff38beb28ec0f63c33bda6a1d39611c98baf (diff)
downloadlibrest-ad370df7c958389f7e814e737d883684ffabbfe8.tar.gz
build: Update the build systemlibrest-0.7.2
• Use an autoconf released in this millenium • Use the LT macros for libtool • Do not create SGML templates for gtk-doc, and speed up the build • Place every build-related file under build/ • Update the introspection.m4 • Use the introspection makefile rules Signed-off-by: Emmanuele Bassi <ebassi@linux.intel.com>
Diffstat (limited to 'rest/Makefile.am')
-rw-r--r--rest/Makefile.am48
1 files changed, 16 insertions, 32 deletions
diff --git a/rest/Makefile.am b/rest/Makefile.am
index c77c39c..e0ca664 100644
--- a/rest/Makefile.am
+++ b/rest/Makefile.am
@@ -52,43 +52,27 @@ test_runner_LDFLAGS = $(librest_@API_VERSION@_la_LIBADD)
# TODO: use gtester
+# intospection
+-include $(INTROSPECTION_MAKEFILE)
+
if HAVE_INTROSPECTION
-BUILT_GIRSOURCES =
+INTROSPECTION_GIRS = Rest-@API_VERSION@.gir
-Rest-@API_VERSION@.gir: $(INTROSPECTION_SCANNER) librest-@API_VERSION@.la
- $(AM_V_GEN)$(INTROSPECTION_SCANNER) -v \
- --namespace Rest --nsversion=@API_VERSION@ \
- --include=GObject-2.0 \
- --include=Soup-2.4 \
- --include=libxml2-2.0 \
- --library=librest-@API_VERSION@.la \
- --libtool="$(top_builddir)/libtool" \
- --pkg gobject-2.0 \
- --pkg libsoup-2.4 \
- --pkg libxml-2.0 \
- --output $@ \
- -I$(top_srcdir) \
- $(addprefix $(top_srcdir)/rest/, $(lib_headers)) \
- $(addprefix $(top_srcdir)/rest/, $(lib_sources))
+Rest-@API_VERSION@.gir: librest-@API_VERSION@.la Makefile
-BUILT_GIRSOURCES += Rest-@API_VERSION@.gir
+Rest_@API_VERSION_AM@_gir_NAMESPACE = Rest
+Rest_@API_VERSION_AM@_gir_VERSION = @API_VERSION@
+Rest_@API_VERSION_AM@_gir_LIBS = librest-@API_VERSION@.la
+Rest_@API_VERSION_AM@_gir_FILES = $(addprefix $(top_srcdir)/rest/, $(lib_headers))
+Rest_@API_VERSION_AM@_gir_CFLAGS = -I$(top_srcdir)
+Rest_@API_VERSION_AM@_gir_INCLUDES = GObject-2.0 Soup-2.4 libxml2-2.0
+Rest_@API_VERSION_AM@_gir_PACKAGES = gobject-2.0 libsoup-2.4 libxml-2.0
-# INTROSPECTION_GIRDIR/INTROSPECTION_TYPELIBDIR aren't the right place to
-# install anything - we need to install inside our prefix.
girdir = $(datadir)/gir-1.0
-gir_DATA = $(BUILT_GIRSOURCES)
+dist_gir_DATA = $(INTROSPECTION_GIRS)
typelibsdir = $(libdir)/girepository-1.0/
-typelibs_DATA = $(BUILT_GIRSOURCES:.gir=.typelib)
-
-%.typelib: %.gir $(INTROSPECTION_COMPILER)
- $(AM_V_GEN) \
- LD_LIBRARY_PATH=.libs${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH} \
- $(INTROSPECTION_COMPILER) \
- --includedir=$(srcdir) \
- --includedir=. \
- $(INTROSPECTION_COMPILER_OPTS) $< -o $(@F)
-
-CLEANFILES += $(BUILT_GIRSOURCES) $(typelibs_DATA)
+typelibs_DATA = $(INTROSPECTION_GIRS:.gir=.typelib)
-endif #HAVE_INTROSPECTION
+CLEANFILES += $(dist_gir_DATA) $(typelibs_DATA)
+endif # HAVE_INTROSPECTION