summaryrefslogtreecommitdiff
path: root/rest/Makefile.am
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2013-06-26 10:47:16 +0200
committerChristophe Fergeau <cfergeau@redhat.com>2013-06-28 16:44:50 +0200
commita63c691b2f1d1dd4d212b27fea0534f2481ebcc8 (patch)
tree164bf03be3d7da1c8873cb37e0f5acc223e79a56 /rest/Makefile.am
parent2b363686aa1cbfa2d778a16b813472f1bf309cbf (diff)
downloadlibrest-a63c691b2f1d1dd4d212b27fea0534f2481ebcc8.tar.gz
Fix compilation with older glibs
configure.ac requires glib 2.24, but librest is making use of glib functions that were added in later releases (g_clear_object, g_simple_async_report_take_gerror_in_idle, ...). This commit adds reimplementation of these functions which will be used when an older glib is present at build time. glib-compat.[ch] come from spice-gtk. https://bugzilla.gnome.org/show_bug.cgi?id=703103
Diffstat (limited to 'rest/Makefile.am')
-rw-r--r--rest/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/rest/Makefile.am b/rest/Makefile.am
index 69e7f5b..f33fcf7 100644
--- a/rest/Makefile.am
+++ b/rest/Makefile.am
@@ -3,6 +3,8 @@ CLEANFILES =
# For some reason I can't use $(librest_@API_VERSION@_la_SOURCES) in
# test_runner_SOURCES, so we have to do this
lib_sources = \
+ glib-compat.h \
+ glib-compat.c \
rest-param.c \
rest-params.c \
rest-proxy.c \