summaryrefslogtreecommitdiff
path: root/rest/Makefile.am
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2013-11-20 13:09:37 +0000
committerEmmanuele Bassi <ebassi@gnome.org>2014-03-10 16:58:42 +0000
commit6aa3de79579399fd63e29d4276582e3023d213d3 (patch)
tree9176d8154fc4446bd48df74e232af22e0e7f840e /rest/Makefile.am
parent218f44c0daa866a54bc6dd16b6500fb8f9338b4b (diff)
downloadlibrest-6aa3de79579399fd63e29d4276582e3023d213d3.tar.gz
Turn on introspection scanner warnings
So we have a fighting chance to actually fix them, instead of sweeping them under the rug. https://bugzilla.gnome.org/show_bug.cgi?id=712747
Diffstat (limited to 'rest/Makefile.am')
-rw-r--r--rest/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/rest/Makefile.am b/rest/Makefile.am
index da2a56b..65b0c64 100644
--- a/rest/Makefile.am
+++ b/rest/Makefile.am
@@ -120,7 +120,7 @@ Rest_@API_VERSION_AM@_gir_FILES = \
Rest_@API_VERSION_AM@_gir_CFLAGS = -I$(top_srcdir)
Rest_@API_VERSION_AM@_gir_INCLUDES = GObject-2.0 Gio-2.0
Rest_@API_VERSION_AM@_gir_PACKAGES = gobject-2.0 libsoup-2.4 libxml-2.0 gio-2.0
-Rest_@API_VERSION_AM@_gir_SCANNERFLAGS = --accept-unprefixed
+Rest_@API_VERSION_AM@_gir_SCANNERFLAGS = --accept-unprefixed --warn-all
Rest_@API_VERSION_AM@_gir_EXPORT_PACKAGES = rest-@API_VERSION@
REST_CINCLUDES=$(patsubst %,--c-include='rest/%',$(shell echo $(lib_headers)))
INTROSPECTION_SCANNER_ARGS = $(REST_CINCLUDES)