summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRoss Burton <ross@linux.intel.com>2009-10-08 11:46:38 +0100
committerRoss Burton <ross@linux.intel.com>2009-10-08 11:46:38 +0100
commit26b0691668fbfdb58b75aa5b0a632ef35e85799b (patch)
tree967e52974bbe02b571c7ff02b199f2c712e5973f /configure.ac
parente16a6f83bcd0bfe4e25f889c853c63698e82c3a7 (diff)
downloadlibrest-26b0691668fbfdb58b75aa5b0a632ef35e85799b.tar.gz
Define the API version
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 08ecc9a..f93f3f1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,6 +3,10 @@ AC_INIT(rest, 0.6)
AM_INIT_AUTOMAKE(AC_PACKAGE_NAME, AC_PACKAGE_VERSION)
AM_CONFIG_HEADER(config.h)
+m4_define([api_version], [0.6])
+AC_SUBST([API_VERSION],[api_version])
+AC_DEFINE_UNQUOTED(API_VERSION, [$API_VERSION], [API version])
+
AC_CANONICAL_HOST
AC_PROG_CC
@@ -47,4 +51,3 @@ AC_OUTPUT([
tests/Makefile
rest.pc
])
-