summaryrefslogtreecommitdiff
path: root/docs/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'docs/meson.build')
-rw-r--r--docs/meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/docs/meson.build b/docs/meson.build
index 6429576..4c5ba64 100644
--- a/docs/meson.build
+++ b/docs/meson.build
@@ -25,3 +25,16 @@ endif
if get_option('gtk_doc')
subdir('reference')
endif
+
+if get_option('man')
+ manpages = ['notify-send']
+
+ foreach page : manpages
+ custom_target(page + '-man',
+ input: page + '.xml',
+ output: page + '.1',
+ command: xsltproc_command,
+ install: true,
+ install_dir: man1dir)
+ endforeach
+endif