summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMarco Trevisan <mail@3v1n0.net>2019-01-31 17:15:27 +0000
committerMarco Trevisan <mail@3v1n0.net>2019-01-31 17:15:27 +0000
commitb7351a39fbee32e4ef39abfb57399a558169deb1 (patch)
tree381e8144e87ae973e9d4df6789f66593e894efb2 /meson.build
parenta1bedfa65eb77373e1afaef2354fa94fc2a565ac (diff)
parent593f2607220ec6d66843e8030eb0d9aa80dd4bb5 (diff)
downloadlibnotify-b7351a39fbee32e4ef39abfb57399a558169deb1.tar.gz
Merge branch 'wip/3v1n0/meson' into 'master'
Build with meson and add CI See merge request GNOME/libnotify!3
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build56
1 files changed, 56 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 0000000..abc83ce
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,56 @@
+project('libnotify',
+ 'c',
+ version: '0.7.7',
+ meson_version: '>= 0.47.0')
+
+gnome = import('gnome')
+pkgconfig = import('pkgconfig')
+
+################################################################
+# libtool versioning
+################################################################
+#
+# +1 : 0 : +1 == new interface that does not break old one.
+# +1 : 0 : 0 == removed an interface. Breaks old apps.
+# ? : +1 : ? == internal changes that doesn't break anything.
+#
+# CURRENT : REVISION : AGE
+#
+LT_CURRENT=4
+LT_REVISION=0
+LT_AGE=0
+
+VERSION_ARRAY = meson.project_version().split('.')
+MODULE_VERSION = '@0@.@1@'.format(VERSION_ARRAY[0], VERSION_ARRAY[1])
+LIBNAME = meson.project_name().split('lib')[1]
+
+default_includes = include_directories('.')
+
+prefix = get_option('prefix')
+includedir = join_paths(prefix, get_option('includedir'))
+docdir = join_paths(prefix, get_option('datadir'), 'doc', meson.project_name())
+
+libnotify_deps = []
+extra_deps = []
+
+gdk_pixbuf_dep = dependency('gdk-pixbuf-2.0')
+glib_dep = dependency('glib-2.0', version: '>= 2.26.0')
+gio_dep = dependency('gio-2.0', version: glib_dep.version())
+gtk_dep = dependency('gtk+-3.0', version: '>= 2.90', required: get_option('tests'))
+
+libnotify_deps = [gdk_pixbuf_dep, gio_dep, glib_dep]
+tests_deps = [gtk_dep]
+
+conf = configuration_data()
+conf.set_quoted('VERSION', meson.project_version())
+configure_file(input: 'config.h.meson',
+ output : 'config.h',
+ configuration : conf)
+
+subdir('libnotify')
+subdir('tools')
+subdir('docs')
+
+if get_option('tests')
+ subdir('tests')
+endif