summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7f8d312..785a6d6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -66,6 +66,15 @@ fi
GOBJECT_INTROSPECTION_CHECK([0.6.4])
+# vapigen
+AS_IF([test "x$found_introspection" = "xyes"],
+ [
+ dnl we need 0.18 for included GStreamer 1.0 vapis
+ VALA_PROG_VAPIGEN([0.18])
+ ]
+)
+AM_CONDITIONAL([HAVE_VAPIGEN], [test "x$VAPIGEN" != "x"])
+
GTK_DOC_CHECK([1.11],[--flavour no-tmpl])
AC_CONFIG_FILES([
@@ -77,6 +86,7 @@ tests/test-discoverer.sh
doc/Makefile
doc/version.xml
data/Makefile
+vala/Makefile
gupnp-dlna-1.1.pc
gupnp-dlna-1.1-uninstalled.pc
])