summaryrefslogtreecommitdiff
path: root/libgupnp-dlna/Makefile.am
diff options
context:
space:
mode:
authorParthasarathi Susarla <partha.susarla@collabora.co.uk>2011-01-06 18:12:13 +0530
committerZeeshan Ali (Khattak) <zeeshanak@gnome.org>2011-01-21 20:12:07 +0200
commitb1c0653b1cfff963e90bfbbbb262a4e75f7e0b30 (patch)
treefaafc7611178e4b7efeb4862542038571c28432e /libgupnp-dlna/Makefile.am
parent146016623735b7b0e7330e31daecb1919487c0bd (diff)
downloadgupnp-dlna-b1c0653b1cfff963e90bfbbbb262a4e75f7e0b30.tar.gz
libgupnp-dlna: Use encoding-profile from plugins-base
- Give up on the local copy of gstprofile (from gst-convenience) and use the encoding-profile api from gst-plugins-base. - Stop using GstEncodingProfile for in memory representation of the on disk XML profiles but rather create GstEncodingProfile on the fly. - We now use a single GstCaps variable each for audio/video and container instead of a GList and merge them as they are processed from the XML file.
Diffstat (limited to 'libgupnp-dlna/Makefile.am')
-rw-r--r--libgupnp-dlna/Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/libgupnp-dlna/Makefile.am b/libgupnp-dlna/Makefile.am
index c8039e1..47d114c 100644
--- a/libgupnp-dlna/Makefile.am
+++ b/libgupnp-dlna/Makefile.am
@@ -12,7 +12,6 @@ LTVERSION = 0:0:0
shareddir = $(datadir)/gupnp-dlna
AM_CFLAGS = -I$(top_srcdir) \
- -I$(top_srcdir)/gst-convenience/gst-libs \
$(LIBXML_CFLAGS) \
$(GST_CFLAGS) \
$(GST_PBU_CFLAGS) \
@@ -39,7 +38,8 @@ libgupnp_dlna_inc_HEADERS = gupnp-dlna-profile.h \
gupnp-dlna-information.h \
gupnp-dlna-discoverer.h
-noinst_HEADERS = gupnp-dlna-load.h
+noinst_HEADERS = gupnp-dlna-load.h \
+ gupnp-dlna-profile-private.h
libgupnp_dlna_1_0_la_SOURCES = gupnp-dlna-information.c \
gupnp-dlna-discoverer.c \
@@ -49,7 +49,6 @@ libgupnp_dlna_1_0_la_SOURCES = gupnp-dlna-information.c \
$(BUILT_SOURCES)
libgupnp_dlna_1_0_la_LIBADD = $(LIBXML_LIBS) \
- $(top_builddir)/gst-convenience/gst-libs/gst/profile/.libs/libgstprofile-gupnp-dlna-0.10.la \
$(GST_PBU_LIBS)
EXTRA_DIST = gupnp-dlna-marshal.list