summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJens Georg <mail@jensge.org>2012-12-05 13:47:34 +0100
committerJens Georg <mail@jensge.org>2012-12-05 13:47:34 +0100
commitdff7a08356c49a9701ecd930588fea61156985ac (patch)
treec66db9a9283e89c090cf35ccc860c0ee47bbcbe9 /configure.ac
parent2e1b32df3c2b5aec1a05f357d58e3ce10d8e2db8 (diff)
downloadgupnp-dlna-dff7a08356c49a9701ecd930588fea61156985ac.tar.gz
Add message about g_clear_pointer
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index b1e4877..019683c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -135,7 +135,8 @@ have_g_clear_pointer='no'
PKG_CHECK_EXISTS([glib-2.0 >= 2.34],
[have_g_clear_pointer='yes'])
AS_VAR_IF([have_g_clear_pointer], [no],
- [GUPNP_DLNA_TEMP_CFLAGS="$CFLAGS"
+ [AC_MSG_CHECKING([for g_clear_pointer])
+ GUPNP_DLNA_TEMP_CFLAGS="$CFLAGS"
CFLAGS="$CFLAGS $GLIB_CFLAGS"
GUPNP_DLNA_TEMP_LIBS="$LIBS"
LIBS="$LIBS $GLIB_LIBS"
@@ -150,7 +151,8 @@ AS_VAR_IF([have_g_clear_pointer], [no],
]])],
[have_g_clear_pointer='yes'])
LIBS="$GUPNP_DLNA_TEMP_LIBS"
- CFLAGS="$GUPNP_DLNA_TEMP_CFLAGS"])
+ CFLAGS="$GUPNP_DLNA_TEMP_CFLAGS"
+ AC_MSG_RESULT([$have_g_clear_pointer])])
AS_VAR_IF([have_g_clear_pointer], [no],
[AC_DEFINE([g_clear_pointer(ptr, func)],