summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorArun Raghavan <arun.raghavan@collabora.co.uk>2010-09-24 19:44:32 +0530
committerArun Raghavan <arun.raghavan@collabora.co.uk>2010-09-24 19:44:32 +0530
commitd4689f1e94955db646ef663b5d6d9176a68cae6f (patch)
tree9de15312be79a6369e8e174ab496e076e5a681d6 /configure.ac
parentd86a8de582b80989f69791677c179fee50305564 (diff)
downloadgupnp-dlna-d4689f1e94955db646ef663b5d6d9176a68cae6f.tar.gz
build: Add library versioning
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 83ea24e..e3aae72 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4,6 +4,21 @@ AM_INIT_AUTOMAKE()
AC_CONFIG_SRCDIR(libgupnp-dlna/gupnp-dlna-profile.h)
AM_CONFIG_HEADER(config.h)
+dnl library versioning
+dnl Increase when changing the API
+GUPNP_DLNA_CURRENT=0
+
+dnl Update when changing implementation of current API,
+dnl reset to 0 when changing CURRENT. This is the revision of
+dnl current API version
+GUPNP_DLNA_REVISION=0
+
+dnl Increase if API change is ABI compatible, otherwise reset to 0
+GUPNP_DLNA_AGE=0
+
+GUPNP_DLNA_VERSION_INFO="$GUPNP_DLNA_CURRENT:$GUPNP_DLNA_REVISION:$GUPNP_DLNA_AGE"
+AC_SUBST(GUPNP_DLNA_VERSION_INFO)
+
m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])],)
AC_ISC_POSIX