summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRiko Yamada <rik0yamada@yahoo.co.jp>2012-06-03 12:44:29 +0900
committerZeeshan Ali (Khattak) <zeeshanak@gnome.org>2012-06-23 17:13:25 +0300
commitbdd1a01c829dfd61d0b823a358492974fbe75c8a (patch)
treefeac2be8b2dc0a51b31c63d4ce58e1336e2a6619 /configure.ac
parentfae1d4e953a389778750151a62941515e737d72e (diff)
downloadgupnp-dlna-bdd1a01c829dfd61d0b823a358492974fbe75c8a.tar.gz
Remove explicit calls to g_thread_init()
With recent glib, g_type_init() initializes the thread system for us and g_thread_init() has been deprecated in GLib-2.32. https://bugzilla.gnome.org/show_bug.cgi?id=673472
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f6b5c54..9db94d4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -50,6 +50,8 @@ AC_SUBST(GST_MAJORMINOR)
GST_CFLAGS="$GST_CFLAGS -DGST_USE_UNSTABLE_API"
AC_SUBST(GST_CFLAGS)
+PKG_CHECK_MODULES(GLIB, glib-2.0 >= 2.24)
+
# glib-genmarshal
GLIB_GENMARSHAL=`pkg-config --variable=glib_genmarshal glib-2.0`
AC_SUBST(GLIB_GENMARSHAL)