summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorJan Tojnar <jtojnar@gmail.com>2019-01-07 16:39:04 +0100
committerVictor Toso <toso@posteo.net>2019-02-08 09:45:49 +0000
commit6eafdbb205128140e5ddba5a871f86ab008fb361 (patch)
tree492b036b0d76c3c9257079950b5b9f0ddb00a163 /src/meson.build
parent335bc779ceb29afa70c1c22c14e5700d09ba7bcf (diff)
downloadgrilo-6eafdbb205128140e5ddba5a871f86ab008fb361.tar.gz
build: Fix path handling in pkgconfigwip/jtojnar/meson-fixes
On Nix, headers, introspection files and vapi files are installed to different prefix than the library. This makes sure that the correct paths are used, thus making the build more portable.
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/meson.build b/src/meson.build
index 36c34b3..2eb46f6 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -120,5 +120,7 @@ if enable_gir
dependencies: [ gobject_dep, gmodule_dep, gio_dep ],
includes: [ 'GObject-2.0', 'GModule-2.0', 'Gio-2.0' ],
install: true,
+ install_dir_gir: girdir,
+ install_dir_typelib: typelibdir,
extra_args: gir_extra_args)
endif