summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid King <davidk@gnome.org>2015-03-23 22:40:06 +0100
committerDavid King <davidk@gnome.org>2015-03-23 22:40:57 +0100
commitc7a7c4765aaef6978b363cf84c9bb87f06bb52c7 (patch)
treedcce184035da5b7e2097a3676e5249f027cae711 /Makefile.am
parent8d4bbdfbc1ea9dd1df5b0a167c72ba33f6d18798 (diff)
downloadgnome-logs-c7a7c4765aaef6978b363cf84c9bb87f06bb52c7.tar.gz
Force the test timezone to UTC
As gl_util_timestamp_to_display() uses the local timezone for timestamp formatting, and the test sample data is in UTC, force the test timezone to also be UTC.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index aaf7117..be1ce8d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -117,6 +117,7 @@ check_SCRIPTS = \
# Tests:
TESTS_ENVIRONMENT = \
LANG=C \
+ TZ=UTC \
MALLOC_CHECK_=2 \
MALLOC_PERTURB_=$$(($${RANDOM:-256} % 256)) \
G_SLICE=debug-blocks