summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPranav Ganorkar <pranavg189@gmail.com>2016-07-23 19:34:00 +0530
committerJonathan Kang <jonathan121537@gmail.com>2016-10-20 10:58:39 +0800
commit3f028d5430e06253fd66c4294a9652d02eb31a21 (patch)
tree6d98c23452a0a12fb3666110d5fd205022645fc0 /Makefile.am
parentb58ad1fcc1973da8869b39e28b65c751619d3036 (diff)
downloadgnome-logs-3f028d5430e06253fd66c4294a9652d02eb31a21.tar.gz
Add search type option to search popover
A radio button group was addded to select between "Exact" and "Substring" search types.The default search type is "Substring" search. We hide the search type radio button group if "All Available Fields" is selected as exact search doesn't make sense in that case. The GlJournalModel class was modified to handle the case when all search fields are exact and there are no substring matches.It was also modified to handle the case when the exact search match string has a null or empty value in which case we do not pass it to gl_journal_set_matches(). GL_QUERY_* prefix was added to the enum nicks for making it consistent with the enum name GlQuerySearchType. https://bugzilla.gnome.org/show_bug.cgi?id=767996
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 762d858..f69b099 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -52,7 +52,8 @@ gnome_logs_enum_headers = \
$(srcdir)/src/gl-eventview.h \
$(srcdir)/src/gl-eventviewrow.h \
$(srcdir)/src/gl-util.h \
- $(srcdir)/src/gl-searchpopover.h
+ $(srcdir)/src/gl-searchpopover.h \
+ $(srcdir)/src/gl-journal-model.h
noinst_gnome_logs_headers = \
src/gl-application.h \