summaryrefslogtreecommitdiff
path: root/libgdict/Makefile.am
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@src.gnome.org>2007-09-06 17:05:16 +0000
committerEmmanuele Bassi <ebassi@src.gnome.org>2007-09-06 17:05:16 +0000
commit7bbe862950ff5b8695fdf1f0e0df1efd1bf8a1e7 (patch)
treed7645a20f34f419869e9494bf28fdb0213c70968 /libgdict/Makefile.am
parent18f7942129dd631ff6955227497ac0641ace9cbe (diff)
downloadgnome-dictionary-7bbe862950ff5b8695fdf1f0e0df1efd1bf8a1e7.tar.gz
Improve GDict debug messages handling
This commit changes the debug messages handling in GDict, using a system similar to the one GLib and GTK+ use. You can either set the GDICT_DEBUG environment variable to a colon-separated or comma-separated list of debug flags, or you can use the --gdict-debug and --gdict-no-debug command line arguments to switch on (and off) the debug flags. The GDICT_NOTE() macro has been added as well, replacing _gdict_debug() for a more comprehensive debug output. The entire debug message system is enabled either by calling the gdict_debug_init() function or by using the GOptionGroup that is returned by gdict_get_option_group(). The debug message system is also depending on whether the GDict library has been compiled with the GDICT_ENABLE_DEBUG flag -- which is the default for development/unstable cycles. svn path=/trunk/; revision=7661
Diffstat (limited to 'libgdict/Makefile.am')
-rw-r--r--libgdict/Makefile.am9
1 files changed, 1 insertions, 8 deletions
diff --git a/libgdict/Makefile.am b/libgdict/Makefile.am
index f86a5d2..5ea890d 100644
--- a/libgdict/Makefile.am
+++ b/libgdict/Makefile.am
@@ -2,12 +2,6 @@
NULL =
-if ENABLE_DEBUG
-GDICT_ENABLE_DEBUG=-DGDICT_ENABLE_DEBUG=1
-else
-GDICT_ENABLE_DEBUG=
-endif
-
INCLUDES = -DG_LOG_DOMAIN=\"Gdict\" \
-DDATADIR=\""$(datadir)"\" \
-DLIBDIR=\""$(libdir)"\" \
@@ -16,7 +10,7 @@ INCLUDES = -DG_LOG_DOMAIN=\"Gdict\" \
-DGNOMELOCALEDIR=\""$(gnomeutilslocaledir)"\" \
-DGDICTSOURCESDIR=\""$(datadir)/gdict-1.0/sources"\" \
-DGDICT_ENABLE_INTERNALS=1 \
- $(GDICT_ENABLE_DEBUG) \
+ $(GDICT_DEBUG_CFLAGS) \
$(DISABLE_DEPRECATED_CFLAGS) \
$(WARN_CFLAGS) \
$(NULL)
@@ -26,7 +20,6 @@ lib_LTLIBRARIES = libgdict-1.0.la
# GNOME Dictionary shared library
libgdict_1_0_la_SOURCES = \
gdict-private.h \
- gdict-debug.c \
gdict-debug.h \
gdict-context.c \
gdict-context.h \