summaryrefslogtreecommitdiff
path: root/libgnome-desktop/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libgnome-desktop/Makefile.am')
-rw-r--r--libgnome-desktop/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/libgnome-desktop/Makefile.am b/libgnome-desktop/Makefile.am
index 79ed33fe..2389eb18 100644
--- a/libgnome-desktop/Makefile.am
+++ b/libgnome-desktop/Makefile.am
@@ -20,12 +20,14 @@ AM_CPPFLAGS = \
AM_CFLAGS = $(WARN_CFLAGS)
+if USE_LIBGSYSTEM
libgsystem_srcpath := libgsystem
libgsystem_cflags = $(GNOME_DESKTOP_CFLAGS)
libgsystem_libs = $(GNOME_DESKTOP_LIBS)
include libgsystem/Makefile-libgsystem.am
noinst_LTLIBRARIES += libgsystem.la
+endif
introspection_sources = \
gnome-desktop-thumbnail.c \
@@ -79,10 +81,13 @@ libgnome_desktop_3_la_LIBADD = \
$(XLIB_LIBS) \
$(LIBM) \
$(GNOME_DESKTOP_LIBS) \
- libgsystem.la \
$(LIBRT) \
$(NULL)
+if USE_LIBGSYSTEM
+libgnome_desktop_3_la_LIBADD += libgsystem.la
+endif
+
libgnome_desktop_3_la_LDFLAGS = \
-version-info $(LT_VERSION) \
-export-symbols-regex "^gnome_.*" \