summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 15 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index c9f0b40f..87474f2c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,6 +7,10 @@ SUBDIRS = \
desktop-docs \
man
+schemadir = $(GCONF_SCHEMA_FILE_DIR)
+schema_DATA = \
+ desktop_gnome_icon_theme.schemas
+
EXTRA_DIST = \
gnome-version.xml.in \
gnome-version.xml \
@@ -18,7 +22,17 @@ EXTRA_DIST = \
xmldocs.make \
intltool-extract.in \
intltool-merge.in \
- intltool-update.in
+ intltool-update.in \
+ $(schema_DATA)
versiondir=$(datadir)/gnome-about
version_DATA=gnome-version.xml
+
+
+# don't do this if we are building in eg. rpm
+install-data-local:
+ if test -z "$(DESTDIR)" ; then \
+ for p in $(schema_DATA) ; do \
+ GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(srcdir)/$$p; \
+ done \
+ fi