summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorKalev Lember <kalevlember@gmail.com>2014-05-20 14:30:29 +0200
committerBastien Nocera <hadess@hadess.net>2014-05-30 11:03:24 +0200
commit08406dc293a24fe90340cc79865a27ac8dd25777 (patch)
treea99bd40108671bb524a79ceae42691ab2b063d3f /tests/Makefile.am
parent7eb66fe1401ffac2264795dba1470958b5b443e3 (diff)
downloadgnome-desktop-08406dc293a24fe90340cc79865a27ac8dd25777.tar.gz
Add testsuite skeleton
https://bugzilla.gnome.org/show_bug.cgi?id=730447
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 00000000..dc9c10a3
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,17 @@
+include $(top_srcdir)/glib-tap.mk
+
+LDADD = $(top_builddir)/libgnome-desktop/libgnome-desktop-3.la $(JSON_LIBS)
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir) \
+ $(GNOME_DESKTOP_CFLAGS) \
+ -DG_LOG_DOMAIN=\"GnomeDesktop\" \
+ $(NULL)
+
+AM_CFLAGS = -g $(WARN_CFLAGS)
+
+test_programs = \
+ wall-clock \
+ $(NULL)
+
+-include $(top_srcdir)/git.mk