summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBenjamin Berg <bberg@redhat.com>2019-11-30 16:49:10 +0100
committerBenjamin Berg <bberg@redhat.com>2019-11-30 19:31:21 +0100
commit791200e749f069087d040fd6248be636de539e44 (patch)
tree413353082714200030a2908e1549625bed52c538 /meson.build
parent5331b019c572de39be6242a58bd613e81de49df6 (diff)
downloadgnome-desktop-791200e749f069087d040fd6248be636de539e44.tar.gz
systemd: Add utility function to start a transient systemd scope
In a systemd world, it is often a good idea to move launched applications outside of the own unit into one of their own. This helper allows to do so in a safe and consistent way.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 6876c2c3..360d6600 100644
--- a/meson.build
+++ b/meson.build
@@ -50,6 +50,8 @@ xkb_config_dep = dependency('xkeyboard-config')
iso_codes_dep = dependency('iso-codes')
x_dep = dependency('x11')
+libsystemd_dep = dependency('libsystemd', required: get_option('systemd'))
+
udev_dep = dependency('libudev', required: get_option('udev'))
# Check for bubblewrap compatible platform
@@ -85,6 +87,7 @@ conf.set('ENABLE_SECCOMP', seccomp_dep.found())
conf.set('HAVE_BWRAP', seccomp_dep.found())
conf.set('_GNU_SOURCE', seccomp_dep.found())
+conf.set('HAVE_SYSTEMD', libsystemd_dep.found())
conf.set('HAVE_UDEV', udev_dep.found())
conf.set('HAVE_TIMERFD', cc.has_function('timerfd_create'))