summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2019-01-08 12:47:05 +0100
committerBastien Nocera <hadess@hadess.net>2019-01-30 11:24:08 +0100
commite83305b981ac160ba8bdd11cd44dd57aa57bb399 (patch)
tree9502e0e1cdc16dd1e6076601ba79ed58999c6882 /meson.build
parent78a29e0ed29c6cef0a77fd541c21dbacdd02a889 (diff)
downloadgnome-desktop-e83305b981ac160ba8bdd11cd44dd57aa57bb399.tar.gz
thumbnail: Fix slow thumbnailer due to missing font cache
On some distributions, the font cache doesn't live in /usr but in /var, which we don't allow access to when sandboxing the thumbnailers. Bind mount the fontconfig cache directory read-only if it lives outside /usr, to speed up thumbnailer startup. Closes: #90
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index ffa66654..e8082566 100644
--- a/meson.build
+++ b/meson.build
@@ -42,6 +42,7 @@ glib_dep = dependency('glib-2.0', version: glib_req)
gio_dep = dependency('gio-2.0', version: glib_req)
gio_unix_dep = dependency('gio-unix-2.0', version: glib_req)
schemas_dep = dependency('gsettings-desktop-schemas', version: schemas_req)
+fontconfig_dep = dependency('fontconfig')
xkb_config_dep = dependency('xkeyboard-config')
iso_codes_dep = dependency('iso-codes')
x_dep = dependency('x11')
@@ -58,6 +59,7 @@ if supported_os.contains(host_os) and not unsupported_cpus.contains(host_cpu)
else
seccomp_dep = dependency('', required: false)
endif
+fontconfig_cache_path = fontconfig_dep.get_pkgconfig_variable('cachedir')
xkb_base = xkb_config_dep.get_pkgconfig_variable('xkb_base')
iso_codes_prefix = iso_codes_dep.get_pkgconfig_variable('prefix')