summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorVincent Untz <vuntz@gnome.org>2012-02-22 15:10:30 +0100
committerVincent Untz <vuntz@gnome.org>2012-02-22 15:11:33 +0100
commit351d2b8a80f6c2f8653f73e7791d94c256e78a80 (patch)
treeec9362a16e3aa5e4e2671df72386e8a7a61524d2 /Makefile.am
parent77f7cb7d9dbc32c360de0eec95488990e38a7da2 (diff)
downloadgnome-desktop-351d2b8a80f6c2f8653f73e7791d94c256e78a80.tar.gz
build: Generate ChangeLog on make dist
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index addf4298..3ba35a2b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -44,5 +44,18 @@ MAINTAINERCLEANFILES = \
$(srcdir)/m4/gtk-doc.m4 \
$(srcdir)/m4/intltool.m4
+CHANGELOG_GIT_RANGE = GNOME_DESKTOP_2_26_1..
+dist-hook:
+ $(AM_V_GEN)if test -d "$(srcdir)/.git"; then \
+ ( echo '# Generated by Makefile. Do not edit.'; echo; \
+ GIT_DIR="$(top_srcdir)/.git" ./missing --run \
+ git log $(CHANGELOG_GIT_RANGE) --no-color -M -C --name-status ) \
+ > ChangeLog.tmp \
+ && mv -f ChangeLog.tmp $(distdir)/ChangeLog \
+ || ( rm -f ChangeLog.tmp ; echo Failed to generate ChangeLog >&2 ); \
+ else \
+ echo A git checkout is required to generate ChangeLog >&2; \
+ fi
+
GITIGNOREFILES = $(PACKAGE)-\*.tar.{gz,bz2,xz}
-include $(top_srcdir)/git.mk