summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Henstridge <james@jamesh.id.au>2004-10-06 11:03:49 +0000
committerJames Henstridge <jamesh@src.gnome.org>2004-10-06 11:03:49 +0000
commit9804d7517741773d4b014a1e06a69e775f1680f9 (patch)
tree69beacad9ae9ab0bcc6d0a2e5c7ace6eb6e48447 /Makefile.am
parent09cc2e04ff3e3fca914d1bc1aa522c7fda6798f6 (diff)
downloadgnome-desktop-9804d7517741773d4b014a1e06a69e775f1680f9.tar.gz
Fixes bug #154647:
2004-10-06 James Henstridge <james@jamesh.id.au> Fixes bug #154647: * configure.in: modernise the configure script a bit. * Makefile.am: add some files to clean lists. * autogen.sh (REQUIRED_AUTOMAKE_VERSION): require >= 1.7. 2004-10-06 James Henstridge <james@jamesh.id.au> * Makefile.am (CLEANFILES): clean $(Directory_DATA)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b7dd3c5e..134392e8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,3 +22,12 @@ EXTRA_DIST = \
versiondir=$(datadir)/gnome-about
version_DATA=gnome-version.xml
@INTLTOOL_XML_RULE@
+
+# ignore scrollkeeper files, which will legitimately exist after uninstall.
+distuninstallcheck_listfiles = find . -type f -print | grep -v scrollkeeper
+
+CLEANFILES = $(version_DATA)
+DISTCLEANFILES = \
+ intltool-extract \
+ intltool-merge \
+ intltool-update