summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlexander Larsson <alexl@redhat.com>2002-09-18 17:59:15 +0000
committerAlexander Larsson <alexl@src.gnome.org>2002-09-18 17:59:15 +0000
commit671b5cc12b4fee55c97b38878b97df11950d001b (patch)
tree8abe28edb41a17a5d6f69fffc28154d2ef5cf0b0 /Makefile.am
parent157d9e318c63e4cf90e08e597ce00a7b46c798cb (diff)
downloadgnome-desktop-671b5cc12b4fee55c97b38878b97df11950d001b.tar.gz
Add schemas file with icon_theme default.
2002-09-18 Alexander Larsson <alexl@redhat.com> * Makefile.am: * configure.in: * desktop_gnome_icon_theme.schemas: Add schemas file with icon_theme default.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 15 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index c9f0b40f..87474f2c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,6 +7,10 @@ SUBDIRS = \
desktop-docs \
man
+schemadir = $(GCONF_SCHEMA_FILE_DIR)
+schema_DATA = \
+ desktop_gnome_icon_theme.schemas
+
EXTRA_DIST = \
gnome-version.xml.in \
gnome-version.xml \
@@ -18,7 +22,17 @@ EXTRA_DIST = \
xmldocs.make \
intltool-extract.in \
intltool-merge.in \
- intltool-update.in
+ intltool-update.in \
+ $(schema_DATA)
versiondir=$(datadir)/gnome-about
version_DATA=gnome-version.xml
+
+
+# don't do this if we are building in eg. rpm
+install-data-local:
+ if test -z "$(DESTDIR)" ; then \
+ for p in $(schema_DATA) ; do \
+ GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(srcdir)/$$p; \
+ done \
+ fi