summaryrefslogtreecommitdiff
path: root/tests/common/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/common/meson.build')
-rw-r--r--tests/common/meson.build23
1 files changed, 23 insertions, 0 deletions
diff --git a/tests/common/meson.build b/tests/common/meson.build
new file mode 100644
index 000000000..4d982f029
--- /dev/null
+++ b/tests/common/meson.build
@@ -0,0 +1,23 @@
+
+
+test_unit = 'test-hostname'
+
+sources = files(
+ test_unit + '.c'
+)
+
+cflags = [
+ '-DTEST_SRCDIR="@0@"'.format(meson.current_source_dir()),
+ '-DTEST_TOPSRCDIR="@0@"'.format(meson.source_root())
+]
+
+exe = executable(
+ test_unit,
+ sources,
+ include_directories : [ top_inc, common_inc ],
+ dependencies : common_deps + [libwidgets_dep],
+ c_args : cflags,
+)
+
+test(test_unit, exe)
+