summaryrefslogtreecommitdiff
path: root/panels/info/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'panels/info/meson.build')
-rw-r--r--panels/info/meson.build24
1 files changed, 3 insertions, 21 deletions
diff --git a/panels/info/meson.build b/panels/info/meson.build
index 13015b96c..dc1c11cb2 100644
--- a/panels/info/meson.build
+++ b/panels/info/meson.build
@@ -64,32 +64,14 @@ deps = common_deps + [
dependency('libgtop-2.0')
]
-panels_libs += static_library(
+info_panel_lib = static_library(
cappletname,
sources: sources,
- include_directories: top_inc,
+ include_directories: [ top_inc, common_inc ],
dependencies: deps,
c_args: cflags
)
-
-test_name = 'test-info-cleanup'
-
-sources = files(
- 'info-cleanup.c',
- test_name + '.c'
-)
-
-cflags += ['-DTEST_SRCDIR="@0@"'.format(meson.current_source_dir())]
-
-exe = executable(
- test_name,
- sources,
- include_directories: top_inc,
- dependencies: deps,
- c_args: cflags
-)
-
-test(name, exe)
+panels_libs += info_panel_lib
# FIXME: workaround for updating different sources code
input_dir = join_paths(meson.source_root(), '..', 'gnome-settings-daemon', 'plugins', 'housekeeping')