summaryrefslogtreecommitdiff
path: root/libgnome-control-center/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libgnome-control-center/Makefile.am')
-rw-r--r--libgnome-control-center/Makefile.am47
1 files changed, 47 insertions, 0 deletions
diff --git a/libgnome-control-center/Makefile.am b/libgnome-control-center/Makefile.am
new file mode 100644
index 000000000..0622e2b94
--- /dev/null
+++ b/libgnome-control-center/Makefile.am
@@ -0,0 +1,47 @@
+NULL =
+
+uidir = $(pkgdatadir)/ui
+
+INCLUDES = \
+ $(CAPPLET_CFLAGS) \
+ $(NULL)
+
+lib_LTLIBRARIES = libgnome-control-center.la
+
+libgnome_control_center_include_HEADERS = \
+ cc-panel.h \
+ cc-shell.h \
+ $(NULL)
+
+libgnome_control_center_la_SOURCES = \
+ cc-panel.c \
+ cc-panel.h \
+ cc-shell.c \
+ cc-shell.h \
+ $(NULL)
+
+libgnome_control_center_la_LDFLAGS = \
+ no-undefined \
+ $(NULL)
+
+libgnome_control_center_la_LIBADD = \
+ $(CAPPLET_LIBS) \
+ $(NULL)
+
+libgnome_control_center_la_LIBTOOLFLAGS = --tag=disable-static
+
+libgnome_control_center_includedir = $(includedir)/gnome-control-center-1/libgnome-control-center
+
+pkgconfigdir=$(libdir)/pkgconfig
+pkgconfig_DATA=libgnome-control-center.pc
+
+EXTRA_DIST = \
+ libgnome-control-center.pc.in \
+ $(NULL)
+
+AM_CPPFLAGS = \
+ -DGNOMELOCALEDIR="\"$(datadir)/locale\"" \
+ -DUIDIR="\"$(uidir)\"" \
+ -DMENUDIR="\"$(menudir)\""
+
+-include $(top_srcdir)/git.mk