summaryrefslogtreecommitdiff
path: root/panels/printers/Makefile.am
diff options
context:
space:
mode:
authorMarek Kasik <mkasik@redhat.com>2010-12-17 13:58:45 +0100
committerMarek Kasik <mkasik@redhat.com>2011-01-18 12:54:22 +0100
commit8c4511b52e292107de932caaa658446f7ce14b0d (patch)
treeda1f1419f98e8cf94d7ae8613a9135ac3c6d80a2 /panels/printers/Makefile.am
parent34e473123e0669094874a4994a110c64fb2cdb44 (diff)
downloadgnome-control-center-8c4511b52e292107de932caaa658446f7ce14b0d.tar.gz
Initial implementation of Printers panel
Created by Marek Kasik, modified by Jon McCann. It has been implemented according to design at: http://live.gnome.org/Design/SystemSettings/Printers (not fully implemented yet)
Diffstat (limited to 'panels/printers/Makefile.am')
-rw-r--r--panels/printers/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/panels/printers/Makefile.am b/panels/printers/Makefile.am
new file mode 100644
index 000000000..ff529ee47
--- /dev/null
+++ b/panels/printers/Makefile.am
@@ -0,0 +1,33 @@
+uidir = $(pkgdatadir)/ui/printers
+dist_ui_DATA = \
+ printers.ui
+
+INCLUDES = \
+ $(PANEL_CFLAGS) \
+ $(DBUS_CFLAGS) \
+ $(GNOMECC_CAPPLETS_CFLAGS) \
+ -DGNOMELOCALEDIR="\"$(datadir)/locale\"" \
+ -DGNOMECC_DATA_DIR="\"$(pkgdatadir)\"" \
+ -DDATADIR="\"$(uidir)\"" \
+ $(NULL)
+
+ccpanelsdir = $(PANELS_DIR)
+ccpanels_LTLIBRARIES = libprinters.la
+
+libprinters_la_SOURCES = \
+ printers-module.c \
+ cc-printers-panel.c \
+ cc-printers-panel.h
+
+libprinters_la_LIBADD = $(PANEL_LIBS) $(CUPS_LIBS) $(DBUS_LIBS)
+libprinters_la_LDFLAGS = $(PANEL_LDFLAGS)
+
+@INTLTOOL_DESKTOP_RULE@
+
+desktopdir = $(datadir)/applications
+desktop_in_files = gnome-printers-panel.desktop.in
+desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
+
+CLEANFILES = $(desktop_in_files) $(desktop_DATA)
+
+-include $(top_srcdir)/git.mk