summaryrefslogtreecommitdiff
path: root/panels/display/meson.build
diff options
context:
space:
mode:
authorIñigo Martínez <inigomartinez@gmail.com>2017-09-11 22:05:40 +0200
committerBastien Nocera <hadess@hadess.net>2018-01-23 10:49:31 +0100
commit0dd386f405f49105880041202eeb270959ec3268 (patch)
tree64496538c87daec35a16a88293141b3fe0543247 /panels/display/meson.build
parent811ba929d4986787277f685a13a43e47c9996236 (diff)
downloadgnome-control-center-0dd386f405f49105880041202eeb270959ec3268.tar.gz
build: Migrate from Intltool to Gettext
Recent versions of Gettext are able to translate several formats that are used in GNOME applications. This patch migrates from Intltool to Gettext by using meson's i18n features. https://bugzilla.gnome.org/show_bug.cgi?id=787588
Diffstat (limited to 'panels/display/meson.build')
-rw-r--r--panels/display/meson.build7
1 files changed, 3 insertions, 4 deletions
diff --git a/panels/display/meson.build b/panels/display/meson.build
index f5aab76f0..ee33b4355 100644
--- a/panels/display/meson.build
+++ b/panels/display/meson.build
@@ -7,13 +7,12 @@ desktop_in = configure_file(
configuration: desktop_conf
)
-# FIXME: You will need a recent intltool or the patch from this bug
-# http://bugzilla.gnome.org/show_bug.cgi?id=462312
-custom_target(
+i18n.merge_file(
desktop,
+ type: 'desktop',
input: desktop_in,
output: desktop,
- command: intltool_desktop_cmd,
+ po_dir: po_dir,
install: true,
install_dir: control_center_desktopdir
)