summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChristian Kellner <christian@kellner.me>2018-03-26 16:18:30 +0200
committerChristian Kellner <christian@kellner.me>2018-04-13 15:08:16 +0200
commit47f241b10ccfc59cb879b15e09f7c9759131a096 (patch)
tree1bbbc0a94e7ed6b8211de9ae35d5142a1751bb1e /meson.build
parentef9d460e72b6c67786bbb3f7ec9c6ee7e960d954 (diff)
downloadgnome-control-center-47f241b10ccfc59cb879b15e09f7c9759131a096.tar.gz
thunderbolt: new panel for device management
Thunderbolt devices need to be approved before they can be used. This is done via the boltd system daemon and gnome-shell. The new panel enables the user to manage thunderbolt devices, i.e.: - forget devices that have previously been authorized - authorize currently unauthorize devices Additionally authorization of devices an be temporarily disabled to ensure no evil device will gain access to the computers resources. File starting with "bolt-" are copied from bolt's source tree and currently correspond to the bolt upstream commit with the id f22b1cd6104bdc2b33a95d9896b50f29a141b8d8 They can be updated from bolt via the update-from-bolt.sh script.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index dfc14f106..fb74d04d1 100644
--- a/meson.build
+++ b/meson.build
@@ -206,6 +206,7 @@ if host_is_linux_not_s390
description: 'Define to 1 if libwacom provides definition for 3D styli')
else
message('Bluetooth and Wacom panels will not be built (no USB support on this platform)')
+ message('Thunderbolt panel will not be built (not supported on this platform)')
endif
config_h.set('BUILD_BLUETOOTH', host_is_linux_not_s390,
description: 'Define to 1 to build the Bluetooth panel')
@@ -215,6 +216,8 @@ config_h.set('BUILD_WACOM', host_is_linux_not_s390,
description: 'Define to 1 to build the Wacom panel')
config_h.set('HAVE_WACOM', host_is_linux_not_s390,
description: 'Define to 1 if Wacom is supportted')
+config_h.set('BUILD_THUNDERBOLT', host_is_linux_not_s390,
+ description: 'Define to 1 to build the Thunderbolt panel')
# Check for info panel
gnome_session_libexecdir = get_option('gnome_session_libexecdir')