summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorCarlos Garnacho <carlosg@gnome.org>2018-10-11 00:41:59 +0200
committerGeorges Basile Stavracas Neto <georges.stavracas@gmail.com>2018-11-07 23:02:10 +0000
commit697789083db6085798a0324a1237d3b93c1d3a01 (patch)
treec9f54f6ab3164304f9ef12353da9bb248766e600 /meson.build
parentd51336c2c27f349eaae48415e3f8d142ef7f1671 (diff)
downloadgnome-control-center-697789083db6085798a0324a1237d3b93c1d3a01.tar.gz
build: Drop all references to clutter-gtk
It's currently just added whenever cheese is enabled, however that should be already an indirect dependency. There is no need for it to explicitly to be explicitly linked here. And same goes for CI Docker files, the dependency will be indirectly installed through cheese anyway.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 0 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index e9e5f7c70..c322d3c8b 100644
--- a/meson.build
+++ b/meson.build
@@ -100,7 +100,6 @@ goa_req_version = '>= 3.25.3'
pulse_req_version = '>= 2.0'
accounts_dep = dependency('accountsservice', version: '>= 0.6.39')
-clutter_gtk_dep = dependency('clutter-gtk-1.0', required: false)
colord_dep = dependency('colord', version: '>= 0.1.34')
gdk_pixbuf_dep = dependency('gdk-pixbuf-2.0', version: '>= 2.23.0')
gio_dep = dependency('gio-2.0')
@@ -151,10 +150,7 @@ endforeach
# Optional dependency for the user accounts panel
enable_cheese = get_option('cheese')
if enable_cheese
- assert(clutter_gtk_dep.found(), 'cheese support requested, but clutter-gtk library is not available. Use -Dcheese=false to build without it.')
-
cheese_deps = [
- clutter_gtk_dep,
dependency('cheese', version: '>= 3.28.0'),
dependency('cheese-gtk', version: '>= 3.5.91')
]