summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2011-03-03 14:12:23 -0500
committerColin Walters <walters@verbum.org>2011-03-03 14:12:23 -0500
commit1b7ce6ee5aec42e614a8fdd04bc3f54bfe1dfc95 (patch)
tree422f80dab2c536bc396c90da7777182b56fbdc9d /configure.ac
parent975c3aea6a416d78d092d98b980ae18e25cb95b3 (diff)
downloadgnome-control-center-1b7ce6ee5aec42e614a8fdd04bc3f54bfe1dfc95.tar.gz
configure: Make cheese detection auto
Simply detect cheese availability, and build with if it is. This helps people jhbuilding the gnome-shell moduleset.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index d69d6017b..2f3d99337 100644
--- a/configure.ac
+++ b/configure.ac
@@ -160,11 +160,14 @@ AM_CONDITIONAL(BUILD_PRINTERS, [test x"$enable_cups" = x"yes"])
# Optional dependency for the user accounts panel
AC_ARG_WITH([cheese],
AS_HELP_STRING([--with-cheese], [enable cheese webcam support]),,
- with_cheese=yes)
+ with_cheese=auto)
if test x"$with_cheese" != x"no" ; then
- PKG_CHECK_MODULES(CHEESE, gstreamer-0.10 cheese-gtk >= 2.29.90)
- AC_DEFINE(HAVE_CHEESE, 1, [Define to 1 to enable cheese webcam support])
+ PKG_CHECK_MODULES(CHEESE, gstreamer-0.10 cheese-gtk >= 2.29.90, [have_cheese=yes], [have_cheese=no])
+ AM_CONDITIONAL(BUILD_CHEESE, test x${have_cheese} = xyes)
+ if test x${have_cheese} = xyes; then
+ AC_DEFINE(HAVE_CHEESE, 1, [Define to 1 to enable cheese webcam support])
+ fi
fi
# This is a hard-dependency for the region and user-accounts panels