summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorWilliam Jon McCann <jmccann@redhat.com>2009-08-22 11:25:29 -0400
committerWilliam Jon McCann <jmccann@redhat.com>2009-08-22 17:15:14 -0400
commit56361c81f324cf633b23fdf1ae9ebb686c09ad6a (patch)
tree060f5b973d4d403d2e7c631ee1fdd7680c3d033b /Makefile.am
parentfe7ee8b8be27cac2afa36ce76600719596a3a569 (diff)
downloadgnome-control-center-56361c81f324cf633b23fdf1ae9ebb686c09ad6a.tar.gz
Add schemas file
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 79f153ea8..e360dee8f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -8,8 +8,16 @@ if HAVE_TYPING_BREAK
SUBDIRS += typing-break
endif
+schemasdir = @GCONF_SCHEMA_FILE_DIR@
+schemas_in_files = gnome-control-center.schemas.in
+schemas_DATA = $(schemas_in_files:.schemas.in=.schemas)
+@INTLTOOL_SCHEMAS_RULE@
+
ACLOCAL_AMFLAGS = -I m4
+CLEANFILES = \
+ $(schemas_DATA)
+
DISTCLEANFILES = \
gnome-doc-utils.make
@@ -33,6 +41,7 @@ MAINTAINERCLEANFILES = \
`find "$(srcdir)" -type f -name Makefile.in -print`
EXTRA_DIST = \
+ $(schemas_in_files) \
MAINTAINERS \
gnome-doc-utils.make
@@ -41,3 +50,12 @@ DISTCHECK_CONFIGURE_FLAGS = --disable-scrollkeeper --disable-update-mimedb
GITIGNOREFILES=m4
-include $(top_srcdir)/git.mk
+
+install-data-local:
+if GCONF_SCHEMAS_INSTALL
+ if test -z "$(DESTDIR)" ; then \
+ for p in $(schemas_DATA) ; do \
+ GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(top_builddir)/$$p >&1 > /dev/null; \
+ done \
+ fi
+endif