summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Wood <thomas.wood@intel.com>2010-05-20 10:01:13 +0100
committerThomas Wood <thomas.wood@intel.com>2010-05-20 10:02:03 +0100
commit3748173b42305194642a918382f835e85f0682ca (patch)
treec934da6d2b06466ffad97c6b9f8291abfc95fea9 /Makefile.am
parenta4073bdb8e0972976d0221d0a9d13498dc8d33ec (diff)
downloadgnome-control-center-3748173b42305194642a918382f835e85f0682ca.tar.gz
Add an example implementation of a settings panelwip/libgnome-control-center
The example panel implements CcPanel and registers itself as extending the panel extension point. It provides a simple "Hello World" message. The example panel is not build by default, but enabled through a configure option.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 4ecf918ba..7bb045f09 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,11 +1,15 @@
SUBDIRS = po libwindow-settings libgnome-control-center shell capplets \
font-viewer help docs
-DIST_SUBDIRS = po libwindow-settings capplets font-viewer help shell typing-break
+DIST_SUBDIRS = po libwindow-settings capplets font-viewer help shell typing-break examples
if HAVE_TYPING_BREAK
SUBDIRS += typing-break
endif
+if BUILD_EXAMPLES
+SUBDIRS += examples
+endif
+
schemasdir = @GCONF_SCHEMA_FILE_DIR@
schemas_in_files = gnome-control-center.schemas.in
schemas_DATA = $(schemas_in_files:.schemas.in=.schemas)