summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2012-12-11 11:46:28 +0100
committerBastien Nocera <hadess@hadess.net>2012-12-11 17:07:39 +0100
commit3686cf7eb8528b19597945e2c19ba0f619ef42f6 (patch)
tree3448698f0f32519d80598cd19a240e985c816065 /Makefile.am
parent80dc7c83cbefdccdfd5591280b5163e29fb9b197 (diff)
downloadgnome-control-center-3686cf7eb8528b19597945e2c19ba0f619ef42f6.tar.gz
shell: Make all control-center plugins static
This makes loading faster, with less I/O, avoids unnecessary code duplication (around 1k lines shaved), and ensures that all the panels link and work appropriately. By the same token, it will stop external panels from being created, and loaded. https://bugzilla.gnome.org/show_bug.cgi?id=690036
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index a57c5f248..6f34c23ec 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,10 +1,10 @@
ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
-SUBDIRS = po egg-list-box shell panels
+SUBDIRS = po egg-list-box panels shell
if BUILD_DOCUMENTATION
SUBDIRS += man
endif
-DIST_SUBDIRS = po shell panels man
+DIST_SUBDIRS = po panels shell man
MAINTAINERCLEANFILES = \
$(srcdir)/INSTALL \