summaryrefslogtreecommitdiff
path: root/tests/io/vcard/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/io/vcard/meson.build')
-rw-r--r--tests/io/vcard/meson.build21
1 files changed, 21 insertions, 0 deletions
diff --git a/tests/io/vcard/meson.build b/tests/io/vcard/meson.build
new file mode 100644
index 0000000..e3946e3
--- /dev/null
+++ b/tests/io/vcard/meson.build
@@ -0,0 +1,21 @@
+io_vcard_files = [
+ 'minimal',
+]
+
+foreach vcard_name : io_vcard_files
+ vcf_file = meson.current_source_dir() / vcard_name + '.vcf'
+
+ # Ideally we'd do this using a preprocessor symbol or something
+ vcf_test_env = environment()
+ vcf_test_env.append('_VCF_FILE', vcf_file)
+
+ test_bin = executable(vcard_name,
+ files('test-vcard-'+vcard_name+'.vala'),
+ dependencies: libcontacts_dep,
+ )
+
+ test(vcard_name, test_bin,
+ suite: 'io-vcard',
+ env: vcf_test_env,
+ )
+endforeach