summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNiels De Graef <nielsdegraef@gmail.com>2017-12-28 16:46:32 +0100
committerNiels De Graef <nielsdegraef@gmail.com>2017-12-28 16:46:32 +0100
commit9286254274565bcc94a243c2d868fe0b7132a2fb (patch)
tree3cf84c2dc946458b112a77e9a664cba76b91e747 /meson.build
parent10e6e8f6589728f2df9ff0418e4304b65040b781 (diff)
downloadgnome-contacts-9286254274565bcc94a243c2d868fe0b7132a2fb.tar.gz
Meson: install search provider to the correct dir.
Also: clean up the directory handling a bit.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 8 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 151a2ad..f6077dd 100644
--- a/meson.build
+++ b/meson.build
@@ -15,9 +15,14 @@ add_project_arguments(
# Some variables
config_h_dir = include_directories('.')
-locale_dir = join_paths(get_option('prefix'), get_option('localedir'))
-pkgdatadir = join_paths(get_option('datadir'), meson.project_name())
-pkglibdir = join_paths(get_option('libdir'), meson.project_name())
+contacts_prefix = get_option('prefix')
+datadir = join_paths(contacts_prefix, get_option('datadir'))
+bindir = join_paths(contacts_prefix, get_option('bindir'))
+libdir = join_paths(contacts_prefix, get_option('libdir'))
+libexecdir = join_paths(contacts_prefix, get_option('libexecdir'))
+locale_dir = join_paths(contacts_prefix, get_option('localedir'))
+pkgdatadir = join_paths(datadir, meson.project_name())
+pkglibdir = join_paths(libdir, meson.project_name())
po_dir = join_paths(meson.source_root(), 'po')
# Dependencies