summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJordan Petridis <jpetridis@gnome.org>2019-10-01 11:05:49 +0300
committerJordan Petridis <jpetridis@gnome.org>2019-10-01 11:05:49 +0300
commitaf91bd62bbd4c831add6e666c10078e29163748b (patch)
tree218016e5b14f37477bed6d6b7fe3ac7a572616b8 /meson.build
parent5d87a8459d19c7e620d7b146b7976742790a5b52 (diff)
downloadgnome-calendar-af91bd62bbd4c831add6e666c10078e29163748b.tar.gz
meson.build: Only depend on git if the profile is development
Git is only needed for getting the short sha to append to the version string in the development version of the application. And as such it shouldn't be required for normal builds.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 77d01ad6..6bdfdc8a 100644
--- a/meson.build
+++ b/meson.build
@@ -34,8 +34,9 @@ calendar_schemadir = join_paths(calendar_datadir, 'glib-2.0', 'schemas')
# Options #
###########
-rev_txt = run_command('git','rev-parse','--short','HEAD').stdout().strip()
if get_option('profile') == 'development'
+ find_program('git')
+ rev_txt = run_command('git','rev-parse','--short','HEAD').stdout().strip()
profile = 'Devel'
name_suffix = ' (Development)'
rev = '-@0@'.format(rev_txt)