summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorGeorges Basile Stavracas Neto <georges.stavracas@gmail.com>2019-05-04 12:28:24 -0300
committerGeorges Basile Stavracas Neto <georges.stavracas@gmail.com>2019-05-04 12:28:24 -0300
commit682e614e4b241e0a1dc505938078cbf9cbcf1804 (patch)
treedcaeb1e731e2dad77ba1b8f4370c3efb828a6830 /meson.build
parentf55b4531efb4525ad28b4164d576d83b08295662 (diff)
downloadgnome-calendar-682e614e4b241e0a1dc505938078cbf9cbcf1804.tar.gz
Remove developer docs
They're essentially useless.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 0 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index b4dc13de..01005f9f 100644
--- a/meson.build
+++ b/meson.build
@@ -37,7 +37,6 @@ calendar_schemadir = join_paths(calendar_datadir, 'glib-2.0', 'schemas')
calendar_buildtype = get_option('buildtype')
calendar_debug = calendar_minor_version.is_odd() or calendar_buildtype.contains('debug')
enable_tracing = get_option('tracing')
-enable_gtk_doc = get_option('documentation')
cc = meson.get_compiler('c')
@@ -174,10 +173,6 @@ subdir('src')
subdir('po')
subdir('tests')
-if enable_gtk_doc
- subdir('doc/reference')
-endif
-
configure_file(
output: 'config.h',
configuration: config_h
@@ -191,6 +186,5 @@ output += ' Compiler ........................: ' + cc.get_id() + '\n\n'
output += ' Development options\n'
output += ' Enable Debug: ...................: ' + calendar_debug.to_string() + '\n'
output += ' Enable Tracing: .................: ' + enable_tracing.to_string() + '\n'
-output += ' Enable Documentation: ...........: ' + enable_gtk_doc.to_string() + '\n\n'
output += ' Now type "ninja -C ' + meson.build_root() + '" to build ' + meson.project_name() + '\n\n'
message(output)