summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorIñigo Martínez <inigomartinez@gmail.com>2018-12-20 15:32:38 +0100
committerIñigo Martínez <inigomartinez@gmail.com>2019-01-11 12:06:01 +0100
commitd88cd6afd1b99c3555356412c802e33544793ff4 (patch)
tree0642e391cc0d0d3d1a14f244130bffef4ed3fc33 /meson.build
parent9b6fcc3f59ad0be53faabb8c84fefaf24dacc475 (diff)
downloadgnome-bluetooth-d88cd6afd1b99c3555356412c802e33544793ff4.tar.gz
build: Use / instead of join_paths
Since meson 0.49, the `/` character can be used to join paths[0], so all the instances of `join_paths` have been replaced. Required meson version has been bumped to 0.49. [0] http://mesonbuild.com/Release-notes-for-0-49-0.html#joining-paths-with-
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 5 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index 3cc6eaa7..0ba2f6eb 100644
--- a/meson.build
+++ b/meson.build
@@ -3,7 +3,7 @@ project(
version: '3.28.2',
license: 'GPL2+',
default_options: 'buildtype=debugoptimized',
- meson_version: '>= 0.43.0',
+ meson_version: '>= 0.49.0',
)
gnomebt_version = meson.project_version()
@@ -20,10 +20,10 @@ gnomebt_gir_ns = 'GnomeBluetooth'
gnomebt_gettext_package = meson.project_name() + '2'
gnomebt_prefix = get_option('prefix')
-gnomebt_datadir = join_paths(gnomebt_prefix, get_option('datadir'))
-gnomebt_localedir = join_paths(gnomebt_prefix, get_option('localedir'))
+gnomebt_datadir = gnomebt_prefix / get_option('datadir')
+gnomebt_localedir = gnomebt_prefix / get_option('localedir')
-gnomebt_pkgdatadir = join_paths(gnomebt_datadir, meson.project_name())
+gnomebt_pkgdatadir = gnomebt_datadir / meson.project_name()
# options
enable_gtk_doc = get_option('gtk_doc')
@@ -46,7 +46,7 @@ gnome = import('gnome')
i18n = import('i18n')
pkg = import('pkgconfig')
-po_dir = join_paths(meson.current_source_dir(), 'po')
+po_dir = meson.current_source_dir() / 'po'
top_inc = include_directories('.')