summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorIñigo Martínez <inigomartinez@gmail.com>2018-12-20 13:11:51 +0100
committerIñigo Martínez <inigomartinez@gmail.com>2019-01-11 11:57:52 +0100
commit364f4a0dc5f4b8b0a6c068ca8f9ecf0b8507ef27 (patch)
tree81f5aef5806db778bc0ee15e9bd6b5b57f9a7859 /meson.build
parentb411df34e634ccd4b5f4619e558c5ffa4736bb26 (diff)
downloadgnome-bluetooth-364f4a0dc5f4b8b0a6c068ca8f9ecf0b8507ef27.tar.gz
build: Remove unnecessary directory variables
Some variables in meson build files are used to set installation directories or used as references to set directory related information. However, many of these directories are unnecessary because they have the same information as the default directory values.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 0 insertions, 7 deletions
diff --git a/meson.build b/meson.build
index d22eb2ba..1c3b19d2 100644
--- a/meson.build
+++ b/meson.build
@@ -16,21 +16,14 @@ gnomebt_api_version = '1.0'
gnomebt_api_name = '@0@-@1@'.format(meson.project_name(), gnomebt_api_version)
gnomebt_gir_ns = 'GnomeBluetooth'
-gnomebt_gir_version = '1.0'
gnomebt_gettext_package = meson.project_name() + '2'
gnomebt_prefix = get_option('prefix')
-gnomebt_bindir = join_paths(gnomebt_prefix, get_option('bindir'))
gnomebt_datadir = join_paths(gnomebt_prefix, get_option('datadir'))
-gnomebt_includedir = join_paths(gnomebt_prefix, get_option('includedir'))
-gnomebt_libdir = join_paths(gnomebt_prefix, get_option('libdir'))
-gnomebt_libexecdir = join_paths(gnomebt_prefix, get_option('libexecdir'))
gnomebt_localedir = join_paths(gnomebt_prefix, get_option('localedir'))
-gnomebt_mandir = join_paths(gnomebt_prefix, get_option('mandir'))
gnomebt_pkgdatadir = join_paths(gnomebt_datadir, meson.project_name())
-gnomebt_pkglibdir = join_paths(gnomebt_libdir, meson.project_name())
# options
enable_gtk_doc = get_option('gtk_doc')