summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Winship <danw@gnome.org>2010-11-04 15:27:08 -0400
committerDan Winship <danw@gnome.org>2010-11-04 15:30:50 -0400
commit414f569be490dadbc210d3cf1cf2b5b647931f67 (patch)
tree52a80a308c2e57a605aad0999750de1077215412 /configure.ac
parentee2af28800ff182453641005db207fc68c309fc6 (diff)
downloadgnome-bluetooth-414f569be490dadbc210d3cf1cf2b5b647931f67.tar.gz
build: fix nautilus-sendto configuration
The code was invoking pkg-config incorrectly, causing the check for nautilus-sendto to always fail. Fixing this then revealed that it was previously also looking at the wrong configure variable name, causing --disable-nautilus-sendto to be a no-op. https://bugzilla.gnome.org/show_bug.cgi?id=634018
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index df884967..3939e590 100644
--- a/configure.ac
+++ b/configure.ac
@@ -106,19 +106,19 @@ PKG_CHECK_MODULES(SENDTO,
dnl nautilus-sendto plugin
AC_ARG_ENABLE(nautilus-sendto,
AS_HELP_STRING([--enable-nautilus-sendto=@<:@no/yes/auto@:>@],
- [build nautilus-sendto plugin]), ,
- enable_nst=auto)
+ [build nautilus-sendto plugin]))
-if test "x$enable_nst" != "xno"; then
+if test "x$enable_nautilus_sendto" != "xno"; then
PKG_CHECK_MODULES(NST,
[
- nautilus-sendto >= $NAUTILUS_SENDTO_REQUIRED < NAUTILUS_SENDTO_MAX_REQUIRED
+ nautilus-sendto >= $NAUTILUS_SENDTO_REQUIRED
+ nautilus-sendto < $NAUTILUS_SENDTO_MAX_REQUIRED
], have_nst="yes", have_nst="no")
else
have_nst=no
fi
-if test "x$enable_nst" = "xyes" -a "x$have_nst" != "xyes"; then
+if test "x$enable_nautilus_sendto" = "xyes" -a "x$have_nst" != "xyes"; then
AC_MSG_ERROR([Couldn't find nautilus-sendto dependencies.])
fi