summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTristan Van Berkom <tristan.van.berkom@gmail.com>2013-04-05 15:15:27 +0900
committerTristan Van Berkom <tristan.van.berkom@gmail.com>2013-04-05 15:18:10 +0900
commit1b165d4815c57ea55d2fb89fba64f4a836b1d67c (patch)
treedf557de2b47a46f270d25c754b4157fa595318e2 /tests/Makefile.am
parentfdd5289f5e711dca74edf6810e244adbba22d7bd (diff)
downloadglade-1b165d4815c57ea55d2fb89fba64f4a836b1d67c.tar.gz
Added new test: add-child.c
The new test tests every parent/child relationship in the base GTK+ catalog, a child is added to the parent, the expected relationship is tested, and unreffing the parent GladeWidget is tested to also finalize the child GladeWidget and both runtime GObjects.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index e8b026d2..80f034ce 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -18,7 +18,8 @@ progs_cflags = \
progs_libs = $(GTK_LIBS) $(GTK_MAC_LIBS)
progs_ldadd = $(top_builddir)/gladeui/libgladeui-2.la
-# Namespace expected names and naming exclusivity tests
+# Test that GladeWidgets and thier runtime objects
+# are created and finalized properly
TEST_PROGS = create-widgets
create_widgets_CPPFLAGS = $(progs_cppflags)
create_widgets_CFLAGS = $(progs_cflags)
@@ -26,5 +27,15 @@ create_widgets_LDFLAGS = $(progs_libs)
create_widgets_LDADD = $(progs_ldadd)
create_widgets_SOURCES = create-widgets.c
+# Test that various types of container widgets
+# successfully parent child types via the
+# GladeWidget / adaptor code
+TEST_PROGS += add-child
+add_child_CPPFLAGS = $(progs_cppflags)
+add_child_CFLAGS = $(progs_cflags)
+add_child_LDFLAGS = $(progs_libs)
+add_child_LDADD = $(progs_ldadd)
+add_child_SOURCES = add-child.c
+
TESTS = $(TEST_PROGS)
TESTS_ENVIRONMENT=$(GLADE_TEST_ENVIRONMENT)