summaryrefslogtreecommitdiff
path: root/gladeui/meson.build
diff options
context:
space:
mode:
authorIñigo Martínez <inigomartinez@gmail.com>2019-07-01 15:00:40 +0200
committerAlberto Fanjul <albertofanjul@gmail.com>2019-07-02 10:04:51 +0000
commit85c40c151031f776958eb055bb02c2fa847f4204 (patch)
tree8cd8499fcec5491257dfc1555af05cb11806f80e /gladeui/meson.build
parent27c2286bd9062d2c77cfc1b0eb26fb02523a50b6 (diff)
downloadglade-85c40c151031f776958eb055bb02c2fa847f4204.tar.gz
build: Do not use a system variable only for Windows
Glade is built in multiple systems and `Windows` is not the only system that needs specific commands. Change the `glade_windows` variable to hold the system value.
Diffstat (limited to 'gladeui/meson.build')
-rw-r--r--gladeui/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/gladeui/meson.build b/gladeui/meson.build
index f0f5bc50..309bc57d 100644
--- a/gladeui/meson.build
+++ b/gladeui/meson.build
@@ -176,7 +176,7 @@ if enable_mac_integration
endif
endif
-if glade_windows
+if glade_system == 'windows'
rc = configure_file(
input: 'glade.rc.in',
output: '@BASELINE@',
@@ -255,7 +255,7 @@ sources = files(
)
ldflags = []
-if glade_windows
+if glade_system == 'windows'
rc = configure_file(
input: 'glade-previewer.rc.in',
output: '@BASELINE@',