summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJuan Pablo Ugarte <ugarte@endlessm.com>2018-02-06 10:21:11 -0300
committerJuan Pablo Ugarte <juanpablougarte@gmail.com>2018-10-30 11:10:06 -0700
commit363fd7839ad0c7320f235d22590e13cbb71e2aab (patch)
tree7b64bfbaa4dfc8187c50c7134093e013f0e9deb7 /configure.ac
parent2ddc72f728f0da04d16464765b0fba9bdb6a3c85 (diff)
downloadglade-363fd7839ad0c7320f235d22590e13cbb71e2aab.tar.gz
Add initial implementation of Automatic Templates
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 177508ee..f1e80131 100644
--- a/configure.ac
+++ b/configure.ac
@@ -168,6 +168,13 @@ AC_CHECK_FUNCS(gtk_print_unix_dialog_new,[have_unix_print=yes]; break,[have_unix
AM_CONDITIONAL(HAVE_GTK_UNIX_PRINT, test x"$have_unix_print" = "xyes")
dnl ================================================================
+dnl Check for _gtk_widget_class_template_unset_only_for_glade() in gtk+
+dnl ================================================================
+LIBS=$GTK_LIBS
+AC_CHECK_FUNCS(_gtk_widget_class_template_unset_only_for_glade,[have_template_unset=yes]; break,[have_template_unset=no])
+AM_CONDITIONAL(HAVE_GTK_TEMPLATE_UNSET, test x"$have_template_unset" = "xyes")
+
+dnl ================================================================
dnl Python for optional python dev libs
dnl ================================================================
PYGOBJECT_REQUIRED_MAJOR=3