summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTristan Van Berkom <tristan.van.berkom@gmail.com>2013-04-05 01:13:56 +0900
committerTristan Van Berkom <tristan.van.berkom@gmail.com>2013-04-05 01:13:56 +0900
commitf1543fca9174f965cbe19db8a0fa0e8f5f5a3ff8 (patch)
treee553fbb0bbb838e248e5b95b2ef9aa53e5ac3615 /configure.ac
parentfc0ea5ea9b33190bc0eef42351957ddee077969a (diff)
downloadglade-f1543fca9174f965cbe19db8a0fa0e8f5f5a3ff8.tar.gz
Added Glade's first unit test (about time !)
This patch clears the way for unit testing, some environment variables are added to ensure unit tests run on code that is not installed but in tree. The added test iterates over all widgets in the catalog, uses the adaptor to create a GladeWidget and asserts that the GladeWidget and it's internal object is finalized after unreferencing the GladeWidget.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5621eec1..b0063063 100644
--- a/configure.ac
+++ b/configure.ac
@@ -256,6 +256,14 @@ dnl ================================================================
AC_CHECK_FUNCS(gtk_builder_add_from_resource)
+dnl ================================================================
+dnl Testing environment
+dnl ================================================================
+GLADE_TEST_ENVIRONMENT='GLADE_TESTING=1 GLADE_PIXMAP_DIR=$(top_builddir)/data/icons GLADE_CATALOG_SEARCH_PATH=$(top_builddir)/plugins/gtk+ GLADE_MODULE_SEARCH_PATH=$(top_builddir)/plugins/gtk+/.libs'
+AC_SUBST(GLADE_TEST_ENVIRONMENT)
+
+
+
AC_SUBST([GLADE_PREFIX])
@@ -298,6 +306,7 @@ po/Makefile.in
doc/Makefile
doc/version.xml
help/Makefile
+tests/Makefile
build/mingw-w64/glade.nsi
])