summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2013-06-24 17:58:24 -0400
committerMatthias Clasen <mclasen@redhat.com>2013-06-26 00:00:24 -0400
commita2ba7b937e585b59983d4b8e3a9793aca918d4a4 (patch)
treee1fc0e8aaa7ea6a765edaffaa074b7e228d50153 /configure.ac
parente29c947a60d149102e80237377607d3971ab22b6 (diff)
downloadglade-a2ba7b937e585b59983d4b8e3a9793aca918d4a4.tar.gz
Add man pages
https://bugzilla.gnome.org/show_bug.cgi?id=703013
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 37d93cfe..ae04c22c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -214,6 +214,22 @@ AM_CONDITIONAL(BUILD_PYTHON, test x"$have_python" = "xyes")
YELP_HELP_INIT
+# ==================================================================
+# Man pages (requires xsltproc)
+# ==================================================================
+
+AC_ARG_ENABLE(man-pages,
+ AC_HELP_STRING([--enable-man-pages],
+ [build manual pages]),,
+ enable_man_pages=yes)
+if test x$enable_man_pages = xyes; then
+ AC_PATH_PROG([XSLTPROC], [xsltproc])
+ if test x$XSLTPROC = x; then
+ AC_MSG_ERROR([xsltproc is required to build manual pages])
+ fi
+fi
+AM_CONDITIONAL(BUILD_MAN_PAGES, test x$enable_man_pages = xyes)
+
dnl ================================================================
dnl Check for windows
dnl ================================================================
@@ -325,6 +341,7 @@ po/Makefile.in
doc/Makefile
doc/version.xml
help/Makefile
+man/Makefile
tests/Makefile
build/mingw-w64/glade.nsi
])
@@ -344,4 +361,5 @@ Configuration:
Introspection Data: ${found_introspection}
Build Reference Manual: ${enable_gtk_doc}
+ Build Manual Pages: ${enable_man_pages}
"