summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorCarlos Perelló Marín <carlos@gnome-db.org>2001-09-02 07:59:26 +0000
committerCarlos Perelló Marín <carlos@src.gnome.org>2001-09-02 07:59:26 +0000
commit5edecc7430a87a73cf63951ba98f25cb3a6fea48 (patch)
tree8184e0cea89b97077a7c83d1bfd221d0a3d332f6 /Makefile.am
parent7c29c80dadff6557627c2be1563d2fcc93d9e73e (diff)
downloadglade-5edecc7430a87a73cf63951ba98f25cb3a6fea48.tar.gz
Modified to use the new GNOME 2.0 config stuff. Removed a dup "#include
2001-08-29 Carlos Perelló Marín <carlos@gnome-db.org> * autogen.sh: * configure.in: * Makefile.am: Modified to use the new GNOME 2.0 config stuff. * src/glade.h: Removed a dup "#include <libintl.h>" * src/main.c: Moved the NLS stuff to be the first at main() and added setlocale (LC_ALL, ""); before the bindtextdomain call Now the l10n works!!!! Thanks Martin for your comments ;-) * src/Makefile.am: popt is checked at configure.in
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 12 insertions, 9 deletions
diff --git a/Makefile.am b/Makefile.am
index b1c40c7f..d08886a5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,6 @@
## Process this file with automake to produce Makefile.in
-SUBDIRS = macros intl src po pixmaps widgets
+SUBDIRS = src po pixmaps widgets
Developmentdir = $(datadir)/gnome/apps/Development
Development_in_files = glade2.desktop.in
@@ -18,14 +18,17 @@ EXTRA_DIST = \
pixmapsdir = $(datadir)/pixmaps
pixmaps_DATA =
+# Now, we are using pkg-config so, we don't need the m4 macros anymore ;-)
+# I suppose that we could disable this.
+
# Install all the Gnome m4 macros we use to build Glade, so we can copy them
# to each project's directory (for Gnome projects).
-install-data-local:
- @$(NORMAL_INSTALL)
- $(mkinstalldirs) $(DESTDIR)$(pkgdatadir)/gnome
- $(INSTALL_DATA) $(srcdir)/macros/Makefile.am $(DESTDIR)$(pkgdatadir)/gnome
- $(INSTALL_DATA) $(srcdir)/macros/autogen.sh $(DESTDIR)$(pkgdatadir)/gnome
- for macro_file in $(srcdir)/macros/*.m4; do \
- $(INSTALL_DATA) $$macro_file $(DESTDIR)$(pkgdatadir)/gnome; \
- done
+#install-data-local:
+# @$(NORMAL_INSTALL)
+# $(mkinstalldirs) $(DESTDIR)$(pkgdatadir)/gnome
+# $(INSTALL_DATA) $(srcdir)/macros/Makefile.am $(DESTDIR)$(pkgdatadir)/gnome
+# $(INSTALL_DATA) $(srcdir)/macros/autogen.sh $(DESTDIR)$(pkgdatadir)/gnome
+# for macro_file in $(srcdir)/macros/*.m4; do \
+# $(INSTALL_DATA) $$macro_file $(DESTDIR)$(pkgdatadir)/gnome; \
+# done