summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaolo Borelli <porelli@gnome.org>2009-04-18 15:39:22 +0200
committerPaolo Borelli <porelli@gnome.org>2009-04-18 15:39:22 +0200
commitd0a70945f322a447ad92f6da66c42930e3347bb8 (patch)
tree23f2019390f48ab447d07fbc566b21ca231f5dcc /Makefile.am
parent2ed0a4a20670fb8507192e8a99a372c063f53298 (diff)
downloadgedit-d0a70945f322a447ad92f6da66c42930e3347bb8.tar.gz
Autogenerated ChangeLog
Actually add the rule to generate the ChangeLog... yay git
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e2a21c643..5f9a2633f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -25,3 +25,24 @@ DISTCLEANFILES = \
intltool-update
DISTCHECK_CONFIGURE_FLAGS = --disable-scrollkeeper --enable-gtk-doc
+
+distclean-local:
+ if test $(srdcir) = .; then :; else \
+ rm -f ChangeLog; \
+ fi
+
+ChangeLog:
+ @echo Creating $@
+ @if test -d "$(srcdir)/.git"; then \
+ (GIT_DIR=$(top_srcdir)/.git ./missing --run git log GEDIT_2_26_1^^.. --stat -M -C --name-status --date=short --no-color) | fmt --split-only > $@.tmp \
+ && mv -f $@.tmp $@ \
+ || ($(RM) $@.tmp; \
+ echo Failed to generate ChangeLog, your ChangeLog may be outdated >&2; \
+ (test -f $@ || echo git-log is required to generate this file >> $@)); \
+ else \
+ test -f $@ || \
+ (echo A git checkout and git-log is required to generate ChangeLog >&2 && \
+ echo A git checkout and git-log is required to generate this file >> $@); \
+ fi
+
+.PHONY: ChangeLog